Baby Pacman July 2015

 Baby Pacman  Comments Off on Baby Pacman July 2015
Jul 222015
 

The weather has been really good outside recently so I did a bit more on the Baby Pacman. Cleaned up the coin door and all of its parts and refitted it. The end is near 🙂

Capcom Commando Repairs

 My Projects  Comments Off on Capcom Commando Repairs
Jul 212015
 

I repaired a couple of Capcom Commando PCB’s recently.

The first PCB was in really good condition, but a visual inspection highlighted a couple of problems. Several of the ribbon cable pins had been bridged together so I undid that:

Also two chips at 3K and 5M on the middle board had been piggy-backed over faulty ones and had just been left like that so I desoldered the chips underneath and replaced them:

On firing the game up the first time I got this:

https://youtu.be/8o3nYlEfZlY

A couple of things I noted:

1) The copyright message was stuck over to the left
2) The soldier had three heads
3) The Commando logo was missing
4) In-game graphics were bad
5) The score at the top was missing
6) All the text was duplicated
7) The game had a yellow tinge to it

To fix the yellow tinge I pressed down on all the colour mix chips and VT5 brought the white back so the chip had a faulty socket which I replaced.

Next I removed all the 2114 RAM from the bottom PCB as they are well known to fail and cause graphics issues. Of the six I tested, one was faulty at 1A:

I replaced this and powered up the PCB again to this:

https://youtu.be/8o3nYlEfZlY?t=41

I then wanted to fix the duplicated text. I knew the fault was likely to be on the middle board as the data was stored in IC 5D. I verified this by removing the chip and powering up the board. All the text that had issues had disappeared, as expected.

So I started to probe around the character rom/ram section and noticed that chip 7K had pin 10 stuck low. I went back a step and noticed that the chip 5J also had pin 6 stuck low, and was not operating according to its datasheet. Removed the chip and tested it and it had failed.

Put a new socket on and new LS86 and the duplicated text and missing logos were back!

However in looking for these problems, the sound on the PCB managed to die so I now had a new problem to look at 🙁

The sound z80 was operating normally, so had a look at the Yamaha 2203’s and noticed the clock pin at pin 38 was dead. So I traced this back to the LS74 @ 11E and that was completely dead. Replaced with a socket and new LS74 and the sound was back.

At this point I thought everything on the list was sorted but all of a sudden I couldn’t credit a game, although sometimes it worked and sometimes it didn’t. I looked at the I/O section and pin 10 of 6B to see if a credit was getting registered when I pressed the credit button. Yes it was, so that’s ok. Then I noticed the enable pins on 6B were stuck high so the chip was not doing anything.

So I traced this back to the 138 @ 3A and the outputs were stuck high, whereas I could see that the inputs into the chip looked sound, so I suspected this chip had failed.

I stuck the logic comparator on it and it confirms problems, so I took the chip out and it tests as failed

New socket and chip on and can now credit the game, as the enable pins are now working as expected. All fixed!

Repair #2

I thought having a fully working Commando would help me fix this second PCB fairly easily….but I was wrong.

It certainly helped me confirm the top and bottom boards were both working ok, so all the faults lay in the middle board

Here is what I was getting to start with:

https://youtu.be/-iirjaieoeg

I spent literally days going through this middle board looking for faults and could not find anything wrong, so then started to suspect the program rom sockets or the IDC connectors, as the game worked ok once after reseating the roms and interconnects. I also flexed the IDC connectors and it made a change on screen so I thought this was the mostly likely fault, but swaped both anyway. Here is the PCB fitted with the new headers fitted:

Fired up the PCB and voila! Game was working as expected and everything was back!

https://youtu.be/-iirjaieoeg?t=37